Monday, May 30, 2005

Asterisk & AMP

The last few weeks have been interesting, I've been training for a double century bicycle ride (200+ miles in one day). A few weeks ago I began training too hard and last week it finally caught up with me after a training century. The next day I was supposed to ride a metric (62 miles) but wasn't up to it. Luckily I decided to take the entire week 'off the bike'. Saturday and Sunday I rode 2 centuries and my legs are telling me they're ready for more. So why would I write about his in my HA BLOG? Well as it turns out that training also turned my mind to mush (you get so tired you don't even want to think about it). Well I now know better and I've decided to take it easy for the rest of the summer. Of course my wife has plenty for me to do also. :-)

So I've been playing with Asterisk, Sipura SPA-3000, Grandstream BT100 and AMP (Asterisk Management Portal). I'm having a great deal of trouble with MYSQL as I think, at some point, I set it up so root couldn't do anything with the databases. Since I'm not an expert with MYSQL I can't figure out how to fix it. Grrr! Now when I try to start up AMP (it's on my Gentoo machine) it really doesn't work and I haven't figured out what it's doing or not doing yet.

I think I've had it with Gentoo, nothing really wrong with it except I really like my System V rc scripts and other System V stuff I grew up on (it's an old AT&T vs. BSD thing). So I hope to setup a new system under Fedora IV (with all it's warts) and move everything over to that. Then on to tackling Asterisk, AMP and the hardware. After that's settled I'm going to get a Cisco 7960 for a few weeks. It's great eye candy and I'm hoping to get it working well enough that my wife will let me keep it (Look, Honey, what followed me home. Can we keep it? ;-)

Monday, May 23, 2005


Sorry I haven't put anything to the blog in a while. Between the email/blog post problems and the fact that I've buried myself in work I've just been too discouraged to post (yeah, I know, really bad excuse!). But I've decided to take a small timeout and put a few notes here (maybe small posts, more often would be better).

I've been busy with several projects, two I can't talk about and the rest I can. All are related to Linux HA. The first is the Smarthome X10 competitor: Insteon. I have the RS232 SDK, thanks to Jennifer @ UnrulyGrrl. I'm currently working on an interface program for it. The first run will just be getting it to work properly with X10. After that it will be trying to figure out the Insteon SDK. This is more than X10 (it's supposed to be a superset of X10).

Next I've spent some more time working with Asterisk, the Open Source PBX. I just purchased a Sipura SPA-3000 (1 FXS (phone port) & 1 FXO (telco line)). I already have a Grandstream BT100 phone and a X100P clone. I had thought of purchasing the Grandstream HT-488 but the FXO port can't be controlled by Asterisk right now (future?). Which doesn't seem to matter at the moment as I can only get the FXS port working right now. I'm having trouble figuring out how to get the FXO port into the dial plan. This stuff isn't easy but it's interesting!

Also, I spent some quality time with CUPS (Common Unix Printer System). Basically what I was trying to figure out was how to send X10 commands to turn on the printer, start a timer to turn off the printer and print to a networked printer. The timer should turn off the printer after n minutes. It would be nice if I can figure out if the printer is still busy and if it is back off and check again before eventually turning off the printer. The best way I found to accomplish sending X10 commands before the print job was to take Jeff Hardy's accsnmp Perl script and modifying it. So far I'm not done but I'm getting there.

I'd like to welcome Mike's Home Automation Gadgets and News to the BLOGs sections it's good to have a few more HA related BLOCs around. I do find it weird that companies haven't contacted me about new products. Especially those who I've previously spoke with on this subject. I think that might change over the next year, we'll see. ;-)

Lastly I really need to get back to my work on the CM15A. I have a few things that could really benefit from that device being supported. Between the CM15A & the Insteon I think we may have a horse race.

As a side note, I'm again able to post my blog via email just not from my main ISP. This is a bit more than frustrating but at least it's workable. I hate the way web interfaces slow down the process. I prefer to write in my own editor (I like emacs, yes I'm one of them ;-) with my own extension. The inherent delays of click to post , click to do this, click to do that is extremely annoying. Had a work around for the email not been found I would have moved the blog so that problem no longer existed. I'm glad I don't have to do much to keep posting. Now I just have to keep posting! :-)